Chess pieces not shown

Ask questions regarding general use of DHTML Chess
Post Reply
cldng1
Posts: 5
Joined: Mon Feb 20, 2017 3:58 pm

Chess pieces not shown

Post by cldng1 » Tue Feb 21, 2017 12:02 pm

Hi Alf,
Thank you for allowing me to be part of the Beta.
I am using the Sydney theme at the moment. I am not married to it, lol.
I followed your very clear instructions. The problem is that there are no chess pieces being shown
either in the preview window in the game editor, or on the post. The board and buttons are there but no chess piece.
thanks a lot,
Steve

alf
Site Admin
Posts: 111
Joined: Sat Feb 18, 2017 11:02 pm

Re: Chess pieces not shown

Post by alf » Tue Feb 21, 2017 12:10 pm

Steve,

Here's a small checklist for you which could help me :)
  • Do you have a link to a test page where I can take a look at the problem?
  • Which browser are you testing with?
  • To rule out browser issues, are you able to see the pieces at this site or wordpresschess.com ?
  • In google chrome, click Ctrl+Shift+i (Cmd+Shift+i on mac), click the Console tab, refresh the page and look for errors.
One thing you can try is to Open the DHTML Chess Settings page in admin and click save. Perhaps there's a bug if you haven't selected a default set of chess pieces.

If that doesn't help, try to select some default pieces in admin("DHTML Chess menu") not starting with "svg_". The svg pieces are vector based. Perhaps there's a problem in some browsers with SVG which I'm not aware of and need to address.

Thanks.

Alf

cldng1
Posts: 5
Joined: Mon Feb 20, 2017 3:58 pm

Re: Chess pieces not shown

Post by cldng1 » Tue Feb 21, 2017 3:15 pm

The link with the test page is here: http://chessforchildren.com/test/
I have the chess pieces selected but I do not have pictures of then
the link to that page is here:
http://chessforchildren.com/wp-admin/ad ... s_top_menu
I also included a screenshot of the page in an attachment.
I have tried changing from svg to regular but still no change.
Steve
Attachments
dhtmlchess.png
dhtmlchess.png (52.07 KiB) Viewed 113023 times

cldng1
Posts: 5
Joined: Mon Feb 20, 2017 3:58 pm

Re: Chess pieces not shown

Post by cldng1 » Tue Feb 21, 2017 3:16 pm

Oh your forum is working fine!

alf
Site Admin
Posts: 111
Joined: Sat Feb 18, 2017 11:02 pm

Re: Chess pieces not shown

Post by alf » Tue Feb 21, 2017 3:41 pm

Steve,

From the error log(Ctrl+Shift+I), I can see that the images are missing.

Example from the log:
GET http://chessforchildren.com/wp-content/ ... ig90wp.png 404 (Not Found)

Something seems to have gone wrong during the installation, but it's hard to tell what the problem is, whether it's a problem with the plugin or some issues on your webserver(space, file access etc). I have checked the zip file and all the required files are there.

* Do you have access to the files on your webserver or access to someone who can help you check it?
* Can you see if there are images inside wp-content/plugins/dhtml_chess/api/. Usually, when something goes wrong with the installation, nothing should work, but in this case, only some files are missing.

Do you have access to anyone you could install the plugin using one of the two first options(copy or command line) ?
You may also try to reinstall the plugin(deactivate,uninstall, upload new)

I will test the upload zip feature tonight on a fresh wordpress site at home to see if it's a problem with the third install option(upload zip).

alf
Site Admin
Posts: 111
Joined: Sat Feb 18, 2017 11:02 pm

Re: Chess pieces not shown

Post by alf » Tue Feb 21, 2017 8:24 pm

Steve,

I have found the bug.

What I need you to do is to

1) deactivate the plugin
2) delete the plugin

This is done in admin

Rename the zip file to dhtml_chess.zip (from dhtml-chess-wordpress.zip)

The zip file has to have the same name as the plugin and the plugin is named dhtml_chess.

Then try to upload dhtml_chess.zip as a new plugin in Wordpress admin.

I'm in the process of renaming the zip officially now.

cldng1
Posts: 5
Joined: Mon Feb 20, 2017 3:58 pm

Re: Chess pieces not shown

Post by cldng1 » Fri Mar 03, 2017 2:45 pm

Thank you,
Alf, it is working great!
Steve

Post Reply

Who is online

Users browsing this forum: No registered users and 2 guests